React 18 is not compatible with Fluent UI and how to work around it in PCF projects

React version 18 has recently been pushed into npm which is great if all of your components support it, however, if you are working with Fluent UI then you may stumble across the following error:

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR!
npm ERR! While resolving: my-app20@0.1.0
npm ERR! Found: @types/react@18.0.8
npm ERR!...

Continue Reading Develop1’s Article on their blog

React 18 is not compatible with Fluent UI and how to work around it in PCF projects

React version 18 has recently been pushed into npm which is great if all of your components support it, however, if you are working with Fluent UI then you may stumble across the following error: npm ERR! code ERESOLVE npm ERR! ERESOLVE unable to resolve dependency tree npm ERR! npm ERR!

Blog Syndicated with Develop1’s Permission

Author: Scott Durow

Share This Post On